Blueprint 5.x - The Pharos Systems TaskMaster service not running and will not stay in a "Started" status.
  • 23 Apr 2024
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Blueprint 5.x - The Pharos Systems TaskMaster service not running and will not stay in a "Started" status.

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Article summary

Symptoms:

  • The Pharos Systems TaskMaster Service stops after a few moments after it is started.

  • An attempt to increase logging levels or change logging settings fails.

  • ERROR: "There was an error while configuring the Pharos Blueprint Enterprise Service. Some kind of disk I/O error occured"

Environment:

  • Pharos Systems Blueprint Enterprise Collector v.5.0 - 5.1


Cause:

This error can be reported for any of the following reasons:

  • The database file is corrupted due to a disk problem.

  • Data in a table or tables is corrupted due to a problem when writing to the disk.

Resolution:

If there is an actual hardware problem with the disk, this should be fixed before anything else is done. Any number of third-party or manufacturer utilities can provide information regarding the status of a disk and offer ways to repair it. If this is a crucial server, a repaired disk is normally a candidate for a replacement.

Once the disk is either eliminated as a reason or resolved:

  1. Use SQLiteMan utility (\Program Files (x86)\PharosSystems\Blueprint\bin\SQLiteMan) to check the SQLite DB file.  On Windows 2008/2012 servers, "Run as Administrator" to remove potential access issues.

  2. Stop all Pharos services, run sqliteman.exe and open the file PharosSystems.Blueprint.Collector.db (\ProgramData\PharosSystems\Blueprint\Data).
    NOTE: If the file cannot be opened, copy the PharosSystems.Blueprint.Collector.db from another Collector after stopping all Pharos Systems services on the working Collector (this prevent the file from being copied in the middle of a read or write operation). Copy the file to the broken server's desktop or some other temporary location.

  3. Use SQLiteMan to open PharosSystems.Blueprint.Collector.db, and delete the contents of all tables except for the Settings table. You can use this syntax:
     DELETE FROM <tablename>

  4. Move the new file back to the original folder location and restart the Pharos Systems services on the Collector.


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