- 09 Apr 2024
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MobilePrint print jobs do not print as configured (color mode, single-sided/double-sided)
- Updated on 09 Apr 2024
- 1 Minute to read
- Print
- DarkLight
- PDF
Environment
Pharos Systems MobilePrint 2.0
Pharos Systems MobilePrint 1.3.x
Pharos Systems Print Center
Pharos Systems WebRelease
Microsoft Windows 2008 R2 Server
Microsoft Windows 2008 Server
Microsoft Windows 2012 R2 Server
Microsoft Windows 2012 Server
Symptoms
Jobs do not print with expected attributes.
Single sided jobs print double sided.
Double sided jobs print single sided.
Black and white jobs print in color.
Color jobs print in black and white.
Cause
While Pharos Systems MobilePrint allows users to change the finishing options of jobs that have already been rendered by the print driver (plex mode, number of copies, color mode, and number of pages per sheet), some driver manufacturers have chosen to use proprietary (non-standard) attributes instead. By manipulating the printer driver configuration and managing the defaults for the user account running the MobilePrint Worker service, much of this can be resolved.
Resolution
Accessing the print queue when the MobilePrint Worker service is running as a domain user:
Log into the server using the account that runs the MobilePrint Worker service.
Accessing the print queue when the MobilePrint Worker service is running as LocalSystem:
Download PS Tools from www.microsoft.com/sysinternals.
Extract to a folder locally on the server.
Start an Administrator command prompt session and change your current directory to that of PS Tools.
Run this command:
psexec -I -s cmd.exe
Type whoami at the prompt to ensure that you're running as "nt authority\system". If not, use the command in Step 4 again. Repeat.
Run this command:
control /name Microsoft.DevicesAndPrinters
That will start Devices and Printers (assuming Win 2k8 or 2012) as LocalSystem.
To change the print queue properties:
Go into Properties for the queue utilizing the third party driver for MobilePrint.
Go to the Configuration tab (if one exists) and ensure that the queue is configured as a Color device and that all necessary options (duplex tray, for example) are enabled for the queue. If there are any "Automatic" settings for a configuration, disable these.
Go to the Advanced tab, click the "Printing Defaults" button. Configure preferences here for SINGLE-SIDED plex mode and COLOR color mode. Click OK and APPLY this change.
While on the Advanced tab. Uncheck the "Enable Advanced Printing Features" option. APPLY this change.
Go to the General tab, click the "Printing Defaults" button. Verify that the preferences here for SINGLE-SIDED finishing and COLOR mode. Click OK and APPLY this change.
Finally, launch the MobilePrint Administrator web page and ensure that the devices using the third-party driver have "Black and White Conversion" handled by the Printer.