- 02 Apr 2024
- 1 Minute to read
- Print
- DarkLight
- PDF
PDF files do not print correctly, or do not print at all
- Updated on 02 Apr 2024
- 1 Minute to read
- Print
- DarkLight
- PDF
Symptoms:
PDF documents do not print correctly
PDF documents print very slowly
PDF documents do not print at all
Environment:
Adobe PostScript printer driver
Adobe PostScript-compatible printer driver
Adobe Acrobat (any edition; any version)
Adobe Acrobat Reader (any version)
Microsoft Windows Server (any version)
Microsoft Windows Workstation (any version)
Pharos Systems Blueprint Enterprise (any version)
Pharos Systems Uniprint Suite (any version)
Cause:
Adobe Acrobat and Acrobat Reader will, when the destination printer driver is Adobe PostScript or PostScript-compatible, pre-write much of the PostScript job data by effectively translating the PDF code (which is based on the Adobe PostScript language) to PostScript. The printer driver must support a function called "PostScript Pass-through" in order for this to occur. In most cases, when a PostScript printer driver does support this function, it is enabled by default. However, most print devices do not have native support for the Adobe PostScript CPSI (Configurable PostScript Interpreter), and use a compatible third-party PostScript-compatible interpreter instead. This can cause problems ranging from inconvenient (the print does not match the formatting or layout of the PDF) to fatal (the job does not print), and anywhere in between (the job processes and prints slowly).
Resolution:
Generally, PostScript pass-through is not needed for proper job processing, but is provided merely as a convenience for those applications (mainly produced by Adobe Systems, but also present in some third-party PostScript workflow software) that can create PostScript independent of the printer driver.
To resolve a PDF printing issue when a PostScript driver is involved, the most healthy resolution is to simply disabled the PostScript pass-through option. The location of the option varies by manufacturer; consult your printer driver's documentation or Help file (or search the Internet) to determine where the setting exists so that it may be disabled. Below are two representative drivers with this function.
The Hewlett-Packard PostScript 3 Universal Print Driver
The Xerox PostScript 3 "Pull Print" driver