The conflict occurred in database 'pharos', table 'transactions', column 'qty'
  • 01 Apr 2024
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The conflict occurred in database 'pharos', table 'transactions', column 'qty'

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Article summary

The following error shows up in the server Application Event Log every few minutes:

Event Type: Error

Event Source: PSDatabaseSvr

Event Category: None

Event ID: 4000

Date: 5/29/2006

Time: 8:22:38 PM

User: N/A

Computer: SERVER_NAME

Description: Caught a general error with message '[PSComDBServer::ComputerSessionInsert] COM -- ADO error: IDispatch error #3119. Description: INSERT statement conflicted with COLUMN CHECK constraint 'CK__transaction__qty__76619304'. The conflict occurred in database 'pharos', table 'transactions', column 'qty'.'


Cause:

This error occurs when data being sent from the Signup Client(s) does not match the expected format of the database. In this case the 'qty' column in the transactions table.

Solution:

This problem should not occur in Pharos 7.1 and later. If upgrading is not currently an option, this problem can be solved as follows:

  1. Run the SQL Profiler using the default trace. This will log the exact query being run against the database, which should provide more information. The Profiler will need to run until the errors are captured.

    Note: before starting you might want to purge the Event Log so that you can start clean and see only the current errors.

  2. Once errors are seen, what you will need to do in order to locate the machines causing the error is to compare the Event Log times (when the error occurs) against the times in the Profile Log. After matching the times look for entries like the sample below (in the TextData column of the Profile log):*** exec computer_session_insert '2252003846245', 'PC_NAME', 2, 'DATE_TIME', -28, 0, 1

    The PC_NAME will be the name of the machine sending the "bad" data.

  3. Once found go to that machine and delete the files:

    SUClientAccessPeriods

    SUClientScheduleReservations

    SUClientSessionData

  4. Restart the machine. This will recreate those files. Check to see if that machine has stopped sending errors.

  5. Verify that the machine(s) are running the current Signup Client software.

For additional information see: The conflict occurred in database 'pharos', table 'computer_transactions'


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