Blueprint: Blueprint Collector does not connect to the Blueprint Analyst. At the same time, the Pharos Blueprint Administrator will show the Collector(s) as "Unreachable"
  • 29 Apr 2024
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Blueprint: Blueprint Collector does not connect to the Blueprint Analyst. At the same time, the Pharos Blueprint Administrator will show the Collector(s) as "Unreachable"

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Article summary

Environment

  • Pharos Blueprint v4.2

  • Pharos Blueprint v5.0

  • Pharos Blueprint v5.1

Symptoms

  • Blueprint Server Configuration tool tests fail for HTTP  resources and there is a general Health Test fail after a minute delay.

  • The Blueprint Administrator application lists all Collectors as “Unreachable”.

  • Updating the status of a Collector within Blueprint Administrator fails.

  • Packet tracing shows communications going to another server during self and health tests using the WPAD (Web Proxy Auto-Discovery) protocol.


Cause

The Blueprint servers are attempting communications with a proxy server for proxy configuration, even though the operating system is not configured to utilize WPAD (as determined through Internet Options > Connections > LAN Settings > Automatically Detect Settings = unchecked). Microsoft .NET, the managed code library around which much of the Blueprint software is developed, may continue to attempt proxy communication with WPAD, even if not specifically configured to do so. As .NET wraps our software, the action causes the Blueprint services (namely, the Pharos Systems Taskmaster service) to also attempt communication via WPAD. This results in a timeout, and communication fails.

Resolution

Configure the .NET library’s Machine.Config file to specifically disable automatic discovery.

Procedure for Blueprint v5.0 and lower:

  1. Open the Machine.Config file found in C:\Windows\Microsoft.NET\Framework\v2.0.50727\CONFIG. Use Notepad with an administrative login.

  2. Make the following entry within the <Configuration> section (do not copy/paste from the web page):
       <system.net>
         <defaultProxy >
           <!-- Disable Autoproxy-->
           <proxy autoDetect="false"/>
         </defaultProxy>
       </system.net>

2. Restart the Pharos Systems services on the Blueprint server(s).

Procedure for Blueprint v5.1:

  1. Open the Machine.Config file found in C:\Windows\Microsoft.NET\Framework\v4.0.30319\CONFIG. Use Notepad with an administrative login.

  2. Make the following entry within the <Configuration> section (do not copy/paste from the web page):
       <system.net>
         <defaultProxy >
           <!-- Disable Autoproxy-->
           <proxy autoDetect="false"/>
         </defaultProxy>
       </system.net>

2. Restart the Pharos Systems services on the Blueprint server(s).
 If the edit fails to correct the problem, modify the Pharos service’s .config file as well (for example: PharosSystems.Blueprint.Taskmaster.exe.config) for the same information. Once the edit(s) has been made, the Pharos services are restarted and communication resumes.


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