- 23 Apr 2024
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Blueprint - Managing "auto-created" or "redirected" print queues in Citrix and Microsoft Terminal Services sessions
- Updated on 23 Apr 2024
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Goal:
Manage the automatically-created or redirected print queue in a Citrix or Microsoft Terminal Services session.
Environment:
Pharos Systems Blueprint Tracker (with or without Toner Savings)
Pharos Systems Blueprint PrintScout
Symptoms:
Disconnected logical printers with "TSxxx" ports
Missing print volume in Pharos Blueprint reports
Cause:
When a user connects to a Citrix or Microsoft Terminal Services session for client or application access, any print queues present on the host Windows session are copied to the remote session as a convenience to the end user (no printer mapping required; immediate, non-administrative access to any locally-attached printer). If a Blueprint Tracker or Print Scout is installed within the session, it is the client software that tracks and manages the print job. The result is that the local port (usually a port called "TSxxx" where "xxx" is a three-digit number, or referred to as ThinPrint port) of the redirected queue is used to define the logical printer created by the Blueprint client.
Because the Blueprint normalization function of the Analyst does not have a rule in place to manage these redirected printer instances, they end up in a "Disconnected Logical Printer" state, and the volume associated with it is not recorded as volume in the reporting database.
Resolution:
There are two methods to manage auto-created or redirected print queues within Blueprint Enterprise. The first option allows for historical data to be preserved and transferred to reporting. The second option is "point forward" and does not preserve historical data.
Option 1. Manual Device Normalization.
In this option, the disconnected Logical Printer is resolved to either an existing or new device. This process is covered in-depth within the Pharos Blueprint Enterpise operations guide. Once complete, a republication of historic data is required to correct/update reports generated for previous dates. This option creates "ongoing effort" on the part of the person or team managing the Blueprint installation. Please note that this option does not require that the Blueprint Tracker be installed on the host computer.
Option 2. Ignoring Auto-created or Redirected Print Queues
In this option, the Blueprint Tracker or Print Scout installed within the Citrix or Microsoft Terminal Services session is configured to ignore these print queue types. Instead, the Blueprint client installed on the host computer is responsible for recording the job, which then references the host's printer queue (which should already be normalized as either a local or network-attached device). To engage this option, do the following within the Citrix or Terminal Services environment:
Launch the Registry Editor as an administrator.
Go to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\PharosSystems\OutputManagement\PrintTracker\PrintProfiler.
Double-click the "IgnoreAutoCreatedClientPrinters" name to bring up the Edit dialog box.
Change the "Base" option to "Decimal" and set the "Value data" to a 1.
Click the "OK" button and exit Registry Editor.
Restart the "Pharos Systems ComTaskMaster" or "Pharos Systems Print Scout" service (depending on client software installed), or alternately, restart the remote session.
This change can be implemented on a session-by-session basis (assuming persistency between sessions), or globally for all connecting sessions.