- 23 Apr 2024
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Blueprint: Resolving a missing or duplicated Blueprint Tracker Machine GUID
- Updated on 23 Apr 2024
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Goal
Resolve a missing or duplicated Machine GUID
Environment
Pharos Blueprint v3.5
Pharos Blueprint v3.6
Pharos Blueprint v4.1
Pharos Blueprint v4.2
Pharos Blueprint v5.0
Change
Blueprint Tracker deployed to Microsoft Windows desktop clients.
Cause
A missing Machine GUID is normally caused by inadvertant deletion of the computer's record in the Blueprint "psbprint" database's "Machines" table.
A duplicated Machine GUID most often happens when a "MSI snapshot" utility is used to convert the provided .EXE installer into .MSI for deployment purposes. The resulting MSI file includes the Windows Registry key and value for the Machine GUID, and this is then applied to every install target, undoing the unique nature that a GUID is supposed to provide.
Resolution
In Blueprint 4.2 and lower:
Run the Uninstall package created by the Blueprint Administrator application. For information on how to create an Uninstall package if one is not available, see "Upgrading and Uninstalling Trackers" in the Pharos Administrator Help pages.
Run the Install package created by the Blueprint Administrator application.
In Blueprint 5.0:
Copy BlueprintTracker.exe from the server's \PharosSystems\Blueprint\Deploy folder to the workstation.
In an administrative command prompt navigate to the directory containing the .EXE and type blueprinttracker.exe /uninstall /clean.
Reboot the workstation, allowing Windows to remove any files that were in use during the removal operation.
Go back into an administrative command prompt and install Blueprint Tracker. Options and syntax can be found on page 20 of the "Tracker Deployment Guide" found in the Blueprint 5.0 installation software.
Exit the command prompt window.
The workstation will now have a valid, unique GUID associated with it.