Blueprint 5.x - The Pharos Systems Event Log service not running and will not stay in a "Started" status.
  • 24 Apr 2024
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Blueprint 5.x - The Pharos Systems Event Log service not running and will not stay in a "Started" status.

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Article summary

Symptoms:

  • The Pharos Systems Event Log Service stops after a few moments after it is started.

  • An attempt to increase logging levels or change logging settings fails.

  • ERROR: "There was an error starting the Pharos Systems Event Log Service. Some kind of disk I/O error occured."

Environment:

  • Pharos Systems Blueprint Enterprise Server Analyst/Collector v.5.0 and greater.Answer


Cause:

This error can be reported for any of the following reasons:

  • The database file is corrupted due to a disk problem.

  • Data in a table or tables is corrupted due to a problem when writing to the disk.

Resolution:

If there is an actual hardware problem with the disk, this should be fixed before anything else is done. Any number of third-party or manufacturer utilities can provide information regarding the status of a disk and offer ways to repair it. If this is a crucial server, a repaired disk is normally a candidate for a replacement.

Once the disk is either eliminated as a reason or resolved:

  1. Go to <Drive>:\ProgramData\PharosSystems\Blueprint\EventLogService.

  2. Delete the file PharosSystems.Blueprint.EventLogService.db.

  3. Start the Pharos Systems Event Log Service.


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