Pharos Blueprint - Pharos Systems Secure Release Service will not start
  • 22 Apr 2024
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Pharos Blueprint - Pharos Systems Secure Release Service will not start

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Article summary

Environment

  • Pharos Blueprint Enterprise v5.0 (any service pack)

  • Pharos Blueprint Enterprise v5.1 (any service pack)

  • Pharos Blueprint Enterprise v5.2 R1 (any service pack)

  • Pharos Blueprint Enterprise v5.2 R2 (any service pack)

Symptoms

  • The Pharos Systems Secure Release Service will not start

  • The Pharos Systems Job Service will not start

  • ERROR: "Service cannot be started. System.Data.SQLite.SQLiteException: file is encrypted or is not a database
    file is encrypted or is not a database."


Cause

During operation, the local SQLite database used by the Secure Release Service and Job Service may become corrupt, normally due to a hard disk problem (bad sector). In order to recover, the SQLite database file must be replaced.  

Resolution

Follow the steps in order, below:

  1. Stop the Pharos Systems Secure Release Service or the Pharos Systems Job Service (NOTE: the Job Service will only be present in Blueprint 5.0 systems; it was rolled into the Secure Release Service in Blueprint 5.1 and newer) services.

  2. On another, working, server, stop the Pharos Systems Secure Release Service or the Pharos Systems Job Service services.

  3. Navigate to C:\ProgramData\PharosSystems\SecureRelease\Database.

  4. Copy the PharosSystems.SecureRelease.Database.db file (not the .bak file) to the problem server to the same file path.

  5. Restart the services on the working server.

  6. On the problem server, navigate to C:\Program Files (x86)\PharosSystems\Blueprint\bin\SQLiteMan.

  7. Launch SQLiteMan.exe as an Administrator.

  8. Go to File > Open and navigate to C:\ProgramData\PharosSystems\SecureRelease\Database.

  9. Choose the PharosSystems.SecureRelease.Database.db file (not the .bak file).

  10. Issue the following command against all tables except the "databaseversion" table:
    DELETE FROM <tablename>
    where <tablename> is the name of the table. Omit the "<" ">" when typing the name.

  11. When complete, quit SQLiteMan.

  12. Delete the .bak file found in C:\ProgramData\PharosSystems\SecureRelease\Database.

  13. Start the Pharos Systems Secure Release Service or Pharos Systems Job Service services.

TIP: Keep a clean (so, right after Step 11) copy of the SQLite database file somewhere safe so that if it should happen again you do not need to disrupt another, working, server to obtain an error-free copy.


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