Blueprint: An Error "Cannot contact the Blueprint Analyst" is received after installing Pharos Blueprint Administrator on a client workstation

Blueprint: An Error "Cannot contact the Blueprint Analyst" is received after installing Pharos Blueprint Administrator on a client workstation


Environment

  • Pharos Blueprint Analyst v5.0

  • Pharos Blueprint Administrator v5.0

Symptoms

  • ERROR: "Cannot contact the Blueprint Analyst or the services are not running."


Cause

 The WCF (Windows Communication Foundation) security settings were different between the client and server.

Resolution

The correct this problem, the WCF security settings between the client and the server must match.

  1. On the Blueprint server, go to \Program Files (x86)\PharosSystems\Blueprint\Bin (NOTE: on a 32-bit server, this would be in \Program Files\PharosSystems\Blueprint\Bin) and copy these files:

    global.serviceModel.behaviors.config
    global.serviceModel.bindings.config
    global.serviceModel.client.config
    global.serviceModel.extensions.config
    global.serviceModel.services.config

  2. Paste them into the \Program Files\PharosSystems\Blueprint\bin directory on the client workstation, overwriting the duplicates.

    There is no need to restart any services or processes on the client.