Blueprint Enterprise - Securing a print queue fails with "Access Denied" message

Symptoms

  • ERROR: "Access was denied. Please rerun this application as a user with permission to manage printers and try again."

  • ERROR: "Unable to set printer information for the printer 'Printer Name'. The request is not supported.

  • Cannot secure a print queue.

Environment

  • Pharos Blueprint Enterprise Secure Queue Configuration utility (all versions)

  • Microsoft Windows Server 2012

  • Microsoft Windows Server 2012 R2

  • Microsoft Windows Server 2016


Cause

This error occurs when the printer driver used to build the print queue is a "Version 4" driver. Microsoft Windows will not allow a third-party port monitor (like the Pharos Secure Port monitor) to be used with a Version 4 printer driver. For more information on the Version 4 printer driver, see the "V4 Printer Driver" article on Microsoft's MSDN website.

Resolution

Change the printer driver to a "Version 3" driver and then secure the queue.