Blueprint - ERROR: "There is no row at position 0" message and Blueprint Administrator quits
  • 09 Apr 2024
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Blueprint - ERROR: "There is no row at position 0" message and Blueprint Administrator quits

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Article summary

Environment:

  • Pharos Blueprint Enterprise Administrator (any version)

Symptoms:

  • ERROR: "The Blueprint Administrator has encountered a fatal error and is about to shut down."

  • ERROR: "There is no row at position 0."


Cause:

"No row at position 0" indicates that an application tried to get data (either from a database, file, or in-memory array) and nothing was returned. In the case of the Administrator application, it means that the ServerSettings.xml file that is created during the Blueprint application startup sequence is either missing a configuration component or is corrupt.

Resolution:

  1. Stop the "Pharos Systems" services on the server.

  2. Navigate to the "Application Data" folder specified during the software installation. By default this is C:\ProgramData\PharosSystems directory on a Windows 2008 server or newer. If the Blueprint Administrator is running as a remote application on Windows 7 or newer, you will go to the same directory.

  3. Go to the Blueprint > SettingsCache directory.

  4. Delete the files inside. If you desire a backup, you may simply add a ".old" extension to the files.

  5. Restart the "Pharos Systems" services.


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