- 23 Apr 2024
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Blueprint Tracker keeps failed jobs on the client machine.
- Updated on 23 Apr 2024
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Cause:
Failed page count jobs are not deleted.
Solution:
When processing print jobs, the Blueprint Tracker temporarily stores spool files in the c:\Program Files\Pharos directory. However these spool files are deleted as soon as the print job is processed and page counted. The XML files are not the actual print jobs, but rather encrypted data that contains the information about the jobs that were processed. It is not advisable to delete the XML files, since these files contain the information about the print jobs and are only stored temporarily on the client workstation if Blueprint Tracker is unable to contact the Collector Server. If XML file is deleted then the print job record may not appear on the Collector Server.
The Blueprint Tracker does leave copies of the spool files in c:\Program Files\PharosSystems\PrintTracker\Spool directory, only in the instances when the Pharos Page Counting engine has failed and Windows Page Count was utilized. You can turn this off by making the following change in the registry on client workstations:
HKEY_LOCAL_MACHINE\SOFTWARE\PharosSystems\PrintTracker
FailHistoryMax - 0
By default FailHistoryMax is set to 5, meaning that the Tracker will store up to 5 spool files. By setting it to 0, the spool files will be deleted shortly after they are copied to the c:\Program Files\PharosSystems\PrintTracker\Spool directory.
In case this fails, we recommend setting up a script to delete spool files if any are left on a workstation. Ensure that this script does not remove any XML files.