- 29 Apr 2024
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Blueprint server configuration tests fail
- Updated on 29 Apr 2024
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Affects: Blueprint 3.5+
Problem
Logging on to Omega terminals or iMFP devices to list print jobs fails.
The Blueprint Server Configuration tester reports failures for one or more of the following tests:
Tracker Web Service
EDI Web Service
File Transfer
The failures indicate permission problems, such as 'The request failed with HTTP status 401: Unauthorized.'
Using Internet Explorer to browse to the address 'http://localhost/PharosEDI/BediService.asmx'; results in a 'You are not authorized to view this page' web page.
The account being used for the Internet Information Services (IIS) anonymous access account has been locked out (as seen in the 'Local Users and Groups' control panel applet).
Cause
The Internet Information Services (IIS) anonymous access account is incorrect and/or has the wrong password supplied. IIS does not validate that the specified account exists or that the password is correct, merely that the password matches a confirmation password. When access attempts are made to one of the Blueprint web services this account is used. If the password is incorrect then Windows will eventually lock out that account because of repeated failed logon attempts.
Resolution
Ensure the account assigned for Internet Information Services (IIS) anonymous access is correct and the password entered is valid:
Configure the account under the 'Default Web Site' properties, 'Directory Security' tab, 'Authentication and access control' section,
OR
If the account is to be used only by Blueprint, then configure it in the same relative location as above, but by using the properties for the 'PharosEDI' and 'PharosSystems' virtual directories directly.
Also configure the account for the Blueprint FTP site if this had access problems. This can be done under the 'Default FTP Site' properties, 'Security Accounts' tab, 'Allow anonymous connections' section.
Run the Blueprint Server Configuration tool tests to ensure the settings are correct and that there are no longer any access problems.
If problems persist and the account details entered are correct, then make and revert a change on in the Blueprint Server Configuration tool (to force the 'Apply' button to enable), and click the 'Apply' button. This reconfigures the Blueprint web & FTP services, ensuring the correct account will be used and grants that account the necessary permissions on the Blueprint directories.