- Print
- DarkLight
- PDF
ERROR: "Unable to find the port:PharosPopupPort" When Installing Pharos Popup on a Microsoft Windows Client
Symptoms
ExitCode = 1, Message="Unable to find the port:PharosPopupPort"
Installation fails with an error
Environment
Pharos Systems Uniprint Popup Client (any version)
Microsoft Windows Workstation (any version)
Cause
The error can be indicative of different things:
There is a problem with the Microsoft Windows Registry, particularly in the
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print key, its subkeys, or any values in that path.The user account running the installer has insufficient rights, usually to the Registry:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors.The command inside the installer that creates the Pharos port is not finished, but the rest of the installer is carrying on.
There is a fundamental issue with the Windows Spooler that is preventing it.
Resolution
If the package is installing successfully on other computers, then the package itself is OK. You may wish to run the System File Checker:
sfc.exe /scannow
This will look at the Windows system files and replace anything that is not correct. Otherwise, the next step is to go after the Windows Registry. In many cases, all you may need to do is use the "Print Server Properties" dialog box and remove any unused drivers and ports and then attempt to install the Pharos Uniprint Popup package again.