ERROR: "Unable to find the port:PharosPopupPort" When Installing Pharos Popup on a Microsoft Windows Client
  • 18 Sep 2024
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ERROR: "Unable to find the port:PharosPopupPort" When Installing Pharos Popup on a Microsoft Windows Client

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Article summary

Symptoms

  • ExitCode = 1, Message="Unable to find the port:PharosPopupPort"

  • Installation fails with an error

Environment

  • Pharos Systems Uniprint Popup Client (any version)

  • Microsoft Windows Workstation (any version)


Cause

The error can be indicative of different things:

  • There is a problem with the Microsoft Windows Registry, particularly in the
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print key, its subkeys, or any values in that path.

  • The user account running the installer has insufficient rights, usually to the Registry:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors.

  • The command inside the installer that creates the Pharos port is not finished, but the rest of the installer is carrying on.

  • There is a fundamental issue with the Windows Spooler that is preventing it.

Resolution

If the package is installing successfully on other computers, then the package itself is OK. You may wish to run the System File Checker:

sfc.exe /scannow

This will look at the Windows system files and replace anything that is not correct. In many cases, all you may need to do is use the "Print Server Properties" dialog box and remove any unused drivers and ports and then attempt to install the Pharos Uniprint Popup package again.

If the above-mentioned information does not help, try the following:

  1. Go to Start Menu > All Programs > Pharos, right click on Uninstaller, and choose Run As Administrator to uninstall popup client.

  2. Go to C:\ProgramFiles (x86) and delete the Pharos folder (and PharosSystems folder if present)

  3. Go to C:\ProgramData and delete any Pharos Folder (and PharosSystems folder if present). The “ProgramData” folder is hidden by default so you have to un-hide it for it to show up.

  4. Open registry editor.

    1. Browse to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Printers and delete any printers created by the Pharos popup (if present).

    2. Browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors and delete key, Pharos Systems Popup Port Monitor, if present.

  5. Restart computer.

  6. Temporarily disable anti-virus or other types of protection software if possible. Then reinstall the Pharos Popup client again (be sure to run the installer as administrator).

If the issue persists after following the information above, please reach out to Pharos Support and provide us the controller.log so we can investigate this issue further.

Note: If you are using an ARM based processor, that might be the reason behind the issue Uniprint is not compatible with ARM-based CPUs.


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