When I am in Blueprint 3.1 / 3.2 the print transactions are not being recorded in the BluePrint database due to MSMQ issues.
  • 04 Mar 2024
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When I am in Blueprint 3.1 / 3.2 the print transactions are not being recorded in the BluePrint database due to MSMQ issues.

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Article summary

When I am in Blueprint 3.1/3.2 the print transactions are not being recorded in the BluePrint database due to MSMQ issues.


Some background information on the incident are found below:

  1. Period end close and reports do not show any print transactions being recorded.

  2. The Blueprint logs (TaskMaster.log) show a repeating error similar to:

    [2008/09/08 18:33:13 P360 T1E44 d TaskMaster] [JobLoggerTask.OnMessageQueuePoll] Polling the '.\Private$\pharossystems_joblogger_queue' message queue

    [2008/09/08 18:33:13 P360 T1E44 i TaskMaster] [JobLoggerTask.GetMessageQueueJob] Retrieving Job 'dc2dc477-05f3-46ce-80fd-299b23a1010a\3635981' from Message Queue

    [2008/09/08 18:33:13 P360 T1E44 e TaskMaster] [JobLoggerTask.GetMessageQueueJob] Unknown Exception. Failed to log the job

    [2008/09/08 18:33:13 P360 T1E44 e TaskMaster] Exception...

    1) Exception Information

    =============================================

    Exception Type: System.InvalidOperationException

    Message: Cannot deserialize the message passed as an argument. Cannot recognize the serialization format.

    HelpLink: NULL

    Source: System.Messaging

    StackTrace Information

    =============================================

    at System.Messaging.BinaryMessageFormatter.Read(Message message)

    at System.Messaging.Message.get_Body()

    at PharosSystems.Core.JobLoggerTask.GetMessageQueueJob(String messageId)

  3. The Blueprint server may also become unresponsive and fail to handle any further interaction with client Trackers.

Cause

A corrupt job has managed to be inserted into one of the Blueprint MSMQ queues.  This job gets stuck in the top of the queue and the Blueprint server never recovers from this and never processes any other jobs in the queue. This results in the print transactions never making it into the database, and hence never being accounted for in reports. It can also cause a leak of resources in the Blueprint server, thus making it unresponsive to client Trackers.

Resolution

  1. Open the 'Computer Management' control panel utility.

  2. Browse to 'Services and Applications->Message Queuing->Private Queues'.

  3. Expand the ‘Queue messages’ node for the affected queue indicated in the error logging (e.g. ‘pharossystems_joblogger_queue’).

  4. Delete the first job in the queue.

  5. Within 5 minutes the rest of the jobs in the queue should start clearing and the logs should indicate no further errors.

  6. If the problem persists, there may be multiple bad jobs in the queue. In this case, right click 'All Tasks' and select 'Purge' for the affected queue.


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