Canon EDI logs show the same user attempting to login every 5 minutes
Symptoms
Viewing EDI logs show the same user attempting to login every 5 minutes.
Viewing the on-device debugging logs shows the transaction reaper start then interrupted by an automatic logout.
Viewing the on-device transaction logs shows transactions in the log.
Cause
A too frequent auto clear timer setting on a Canon MFP can interfere with the off-line transaction reaper thread causing it to exit prematurely. This happens before the retry count is incremented so the retry count is always 1.
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How to reproduce:
Set the auto clear timer on the Canon MFP to 20 seconds. (this is for illustration only, other values may also cause the issue
Login
Start a copy job
Unplug the network cable
Let the job complete.
Wait 15 seconds or so
Plug the network cable in
Logout
Wait about 5 minutes
View the on-device logs and note when the transaction reaper runs and if it completes.
View the on-device transaction cache and determine if off-line transactions still exist
View the EDI logs and not if the user is attempted to login at 5 minute interval
Repeat 9-12 three more times to ensure the transaction reaper ran at least 15 minutes
If transactions remain, the issue is exhibiting.
Note that in step 4, any error could cause the job to fail to commit to Pharos. Edi server is down, etc.
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Work Around
Change the auto clear timer to a larger value
Clear the on-device transaction cache.
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How to change the auto-clear timer:
You should not need to uninstall the Pharos solution to do this, but you will have to login. If you find that you can’t change the auto clear timer with Pharos installed perform the following steps
Login to SMS
Disable the Pharos Login Service
Reboot
Change the auto clear timer
Login to SMS
Enable the Pharos Login Service
Reboot
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How to Clear the error
Clear the on-device transaction cache
CTRL-A
CTRL-C
Paste the information for later use
Press the Clear Transactions button