- 19 Mar 2024
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Re-creating the Pharos Reports ODBC Connection
- Updated on 19 Mar 2024
- 2 Minutes to read
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Goal:
Re-create the Pharos Reports ODBC Connection?
Environment:
Pharos Uniprint Suite v7.2 - v9.0
Microsoft Windows Server 2000-2012
Microsoft Windows Workstation XP - 8.1
Cause
When Pharos Reports is installed on a server or workstation remote to the Pharos Uniprint Principal Server, it uses an ODBC (Open Database Connectivity) connection called a DSN (Data Source Name) on the computer. There is a potential that you may either need to recreate or edit this connection (corruption, server information change).
Resolution
To add an ODBC connection:
Go to Start > Settings > Control Panel > Administrative Tools > Data Sources (ODBC).
Go to the System DSN tab.
Click "Add".
Select SQL Server from the list and click "Finish".
Specify the name of the data source as PHAROSReports, type the host name (and SQL instance name, if applicable) of the server hosting the 'pharos' database in the "Server" field and click "Next". NOTE: 1) The "Description" field is optional. 2) If typing in the host name\instance does not provide a successful connection, try typing in only the host name without the instance.
Select the radio button "With SQL server authentication..." and specify a Login ID and Password that can access the database.
Click "Client Configuration" and confirm that the TCP/IP radio button is selected under "Network libraries", the correct server alias and the server name is specified (the host name of your Pharos Principal Server). Also confirm that the correct TCP Port is shown. Click "OK".
Click "Next".
Check the "Change the default database to" checkbox, select "pharos" from the list and click "Next".
Click "Finish".
Click "Test Data Source..." to confirm the connection works, click "OK" and "OK" to exit Data Sources.
Once this is done, test Pharos Reports. If it still fails, in step 7 specify the server IP address instead of the host name for the server alias.
To modify an ODBC connection:
Go to Start > Settings > Control Panel > Administrative Tools > Data Sources (ODBC).
Go to the System DSN tab.
Select the PHAROSReports item and click "Configure...".
Retain the name of the data source as PHAROSReports, change the host name (and SQL instance name, if applicable) of the server hosting the 'pharos' database in the "Server" field (if needed) and click "Next". NOTE: The "Description" field is optional.
Select the radio button "With SQL server authentication..." and specify a Login ID and Password that can access the database.
Click "Client Configuration" and confirm that the TCP/IP radio button is selected under "Network libraries", the correct server alias and the server name is specified (the host name of your Pharos Principal Server). Also confirm that the correct TCP Port is shown. Click "OK".
Click "Next".
Check the "Change the default database to" checkbox, select "pharos" from the list and click "Next".
Click "Finish".
Click "Test Data Source..." to confirm the connection works, click "OK" and "OK" to exit Data Sources.
Once this is done, test Pharos Reports. If it still fails, in step 7 specify the server IP address instead of the host name for the server alias.