All Products: Testing a Device's Support of the LPD Protocol
  • 02 Apr 2024
  • 2 Minutes to read
  • Dark
    Light
  • PDF

All Products: Testing a Device's Support of the LPD Protocol

  • Dark
    Light
  • PDF

Article summary

Goal:

  • Determine if a print device supports the Line Printer Daemon (LPD) protocol required for Pharos Secure Release Here job release.

Environment:

  • Pharos Blueprint Enterprise (all versions)

  • Pharos Uniprint Suite v8.3

  • Pharos Uniprint Suite v8.4

  • Pharos Omega terminals

  • Pharos iMFP terminals


Cause:

Pharos Blueprint Enterprise and Pharos Uniprint 8.3 and 8.4 require that the device support the LPD protocol, as these software products use the associated LPR (Line Printer Remote) protocol to send the job from the server in a Secure Release HereTM workflow. This also applies to "Direct Print" configurations in Uniprint 8.3 and 8.4. The "Resolution" section will help you determine if your device(s) has the LPD protocol enabled.

Resolution:

To test, you must first have the LPR client software installed on the computer from which you will testing. The process is different if you are using a Microsoft workstation or server:

Microsoft Windows 7/8

In Control Panel, click Programs and Features, click Turn Windows features on or off, expand Print and Document Services, select the LPR Port Monitor check box, and then click OK.

Microsoft Server 2008/2012 (including any "R2" version)

In Server Manager, click Add Features, select the LPR Port Monitor check box, and then click OK.

Test Using the LPR Protocol

  1. Create a text file with something in it. "The quick brown fox..." is an excellect choice.

  2. Use the LPR command line to submit this job to the device. The syntax for the LPR command is:     

    lpr -S <IP address of printer> -P <LPR queue name> <Filename>.txt

    NOTE: The "S" and the "P" must be uppercase. Further, ensure that spaces are used after each.

    NOTE: It is also important that, if required by the device, the LPR queue name be used. This queue name varies by manufacturer and sometimes by model. For your convenience, the more popular queue names are listed below. Please consult with your device manufacturer's Product Installation Guide or Technical Support group to verify the correct queue name for your device. This queue name must also be specified when setting up your terminal (Pharos Blueprint Enterprise) or device (Pharos Uniprint) for the best possible user experience. Be aware the queue names are case-sensitive.

  Manufacturer

  LPR Queue Name

 Canon, Inc.

 Canon UFR II/Multi-PDL: lp (as in Line Printer) or SPOOL  ColorPASS/imagePASS controllers: print

 Hewlett-Packard

 raw1

 Konica-Minolta

 Non-EFI controller: Print (note the uppercase "P")  EFI controller: print (note the lowercase "p")

 Lexmark

 port1

 Ricoh

 Non-EFI controller: lp (as in Line Printer)  EFI controller: print

 Xerox 

 raw

Test using the LPQ (Line Printer Query) Command

You could also use the LPQ command. Note that similarity between LPQ and LPR, but no file is required for LPQ:     

lpq  -S <ip of printer> -P <LPR queue name>

NOTE: If desired, you can add the -l switch for verbose output. 

If you are not able to LPR a print job to the device, or determine the queue's status via LPQ, neither Pharos Blueprint nor Uniprint will be successful when attempting to release a print job. In some cases, a failure may be due to simply not having the LPD protocol enabled in the device's network/network services configuration. Other reasons include:

  • Using the wrong, or no, LPR queue name

  • A network device (router, firewall, proxy server) blocking or capturing the traffic. The LPD service listens over TCP port 515.


Was this article helpful?


Changing your password will log you out immediately. Use the new password to log back in.
First name must have atleast 2 characters. Numbers and special characters are not allowed.
Last name must have atleast 1 characters. Numbers and special characters are not allowed.
Enter a valid email
Enter a valid password
Your profile has been successfully updated.